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Legal notice
Copyright and trademark information relating to this product release.
Copyright © 2000–2021 SDL as part of the RWS Holdings Plc group of companies ("RWS Group").
SDL means SDL Limited and its subsidiaries and affiliates. All intellectual property rights contained herein
are the sole and exclusive rights of SDL. All references to SDL shall mean SDL Limited and its subsidiaries
and affiliates details of which can be obtained upon written request.
All rights reserved. Unless explicitly stated otherwise, all intellectual property rights including those in
copyright in the content of this website and documentation are owned by or controlled for these purposes
by SDL. Except as otherwise expressly permitted hereunder or in accordance with copyright legislation, the
content of this site, and/or the documentation may not be copied, reproduced, republished, downloaded,
posted, broadcast or transmitted in any way without the express written permission of SDL.
Trados Studio is a registered trademark of SDL. All other trademarks are the property of their respective
owners. The names of other companies and products mentioned herein may be the trademarks of their
respective owners. Unless stated to the contrary, no association with any other company or product is
intended or should be inferred.
This product may include open source or similar third-party software, details of which can be found by
clicking the following link: “Acknowledgments”.
Although RWS Group takes all reasonable measures to provide accurate and comprehensive information
about the product, this information is provided as-is and all warranties, conditions or other terms
concerning the documentation whether express or implied by statute, common law or otherwise
(including those relating to satisfactory quality and fitness for purposes) are excluded to the extent
permitted by law.
To the maximum extent permitted by law, RWS Group shall not be liable in contract, tort (including
negligence or breach of statutory duty) or otherwise for any loss, injury, claim liability or damage of any
kind or arising out of, or in connection with, the use or performance of the Software Documentation even
if such losses and/or damages were foreseen, foreseeable or known, for: (a) loss of, damage to or
corruption of data, (b) economic loss, (c) loss of actual or anticipated profits, (d) loss of business revenue,
(e) loss of anticipated savings, (f) loss of business, (g) loss of opportunity, (h) loss of goodwill, or (i) any
indirect, special, incidental or consequential loss or damage howsoever caused.
All Third Party Software is licensed "as is." Licensor makes no warranties, express, implied, statutory or
otherwise with respect to the Third Party Software, and expressly disclaims all implied warranties of noninfringement, merchantability and fitness for a particular purpose. In no event will Licensor be liable for
any damages, including loss of data, lost profits, cost of cover or other special, incidental,
consequential, direct, actual, general or indirect damages arising from the use of the Third Party
Software or accompanying materials, however caused and on any theory of liability. This limitation
will apply even if Licensor has been advised of the possibility of such damage. The parties
acknowledge that this is a reasonable allocation of risk.
Information in this documentation, including any URL and other Internet website references, is subject to
change without notice. Without limiting the rights under copyright, no part of this may be reproduced,
stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic,
mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written
permission of RWS Group.
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Product overview

Trados Studio is a Computer Aided Translation (CAT) tool and translation memory software that
helps you translate and manage translation projects faster and easier.
Trados Studio offers a complete environment for professional translators to edit and review
projects, use agreed terminology and leverage machine translation results. As a project
manager, you can use Trados Studio to effectively manage all aspects of translation projects.
See the online Help for information on using Trados Studio.
Product names
As part of the integration of SDL into the RWS group the products have been renamed
as follows:


SDL Trados Studio - Trados Studio



SDL Trados GroupShare – Trados GroupShare



SDL MultiTerm - MultiTerm



SDL Language Cloud - RWS Language Cloud



SDL Trados Live - Trados Live



SDL Trados Live Essential - Trados Live Essential



SDL Trados Live Team - Trados Live Team



SDL Language Cloud Translation Management – Trados Enterprise

Freelancer and Starter versions


The Freelance and Starter versions of Trados Studio cannot run on a domain-based
network. This is the intended behavior for these two versions. If you want to run Trados
Studio on a domain-based network, use the Express, Professional or the Studio
Workgroup version instead.



See the Studio comparison table for more information on the differences between the
Trados Studio editions.

RWS AppStore


Download apps which extend the default functionality of Trados Studio.

Cloud references
In this guide, the tem "cloud" covers all RWS product offerings powered by the RWS
Language Cloud:


Trados Live Essential



Trados Live Team



Trados Enterprise
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Changes introduced in Trados Studio 2021 SR2

The SR2 release greatly expands on Trados Studio’s cloud capabilities, Unicode processing,
security, and brings many more improvements for a smoother, faster, and more robust way
of working. Find the full list of improvements below or watch the What’s new in Trados Studio
2021 SR2 video.

2.1

Save local projects to cloud

You now have the option to save your locally created projects and Studio project packages to
cloud.
This means that you can use Trados Studio specific features such as PerfectMatch, 65+ NMT
providers, a batch processing app and many more capabilities to preprocess your content, and
later create a cloud project based on your local project.
You will gain benefits such as back-ups, syncing across devices, access to the Online Editor and
more. This way you can combine the best of both worlds – prepare content using Studio’s
powerful features, then move it to the cloud to benefit from its processing power and the new
sharing and flexible workflow capabilities.
For information on how to save local resources to cloud, see Saving local projects to cloud in the
Online Help or watch How to save local projects to cloud video.

2.2

Migrate translation memories to cloud

or your local translation memories ( TMs). You can now easily migrate your local TMs to the cloud
through an easy-to-use wizard for batch conversions.
Cloud TMs that you create from local TMs can be used in cloud projects as part of your translation
engines. With this feature, you can also merge multiple local TMs into cloud TMs and migrate
several language pairs in one go.
For more information on migrating local TMs to cloud, see Migrate TMs to cloud in the Online
Help or watch How to migrate TMs to cloud video.

2.3

Added support for Emoji characters

Emojis are now fully preserved when translating in Trados Studio or in the cloud.
With this update, Trados Studio can recognize over 3500 emojis. In Trados Studio's Editor,
emojis are displayed as placeholder tags. This not only guarantees backward and forward
compatibility with other Trados Studio versions but also with the Online Editor where emojis are
displayed as real characters in the preview.
While most file types in Trados Studio have been updated, Emoji support for those remaining,
will become available in a future Cumulative Update.
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2.4

Improved character handling and Unicode support

Trados Studio 2021 SR2 improves the handling of characters. File types have been enhanced to
support a wider range of Unicode encoded characters.
With the new implementation of Unicode Standard Version 13, Trados Studio can render and
preserve a multitude of special characters such as:


Special non-Latin script characters



Mathematical symbols



Scientific symbols



Ideographs

See the list of improved file types on page 9.

2.5

Multi-factor authentication for cloud projects

With the recent introduction of MFA in our cloud platform, working with cloud projects from
Trados Studio has become even more secure.
When signing into your cloud account, users added to the new MFA group are now required to
also provide an MFA code in addition to their regular cloud credentials. This adds an extra layer
of security for accessing sensitive cloud projects by requiring an additional time-based one-time
password via Google Authenticator, Microsoft Authenticator, Authy, or any other MFA provider.
For more information on how to enable and use MFA, see Adding users with multi-factor
authentication access in the Language Cloud documentation.

2.6

Automatic task assignment to the project creator

Trados Studio is able to map the project creator to the task assignee in cloud workflows.
When creating a new cloud workflow, you now have the ability to set "Project Creator" as
assignee for the Translation and Review tasks. This means that every time you use that
workflow when creating a new cloud project from Trados Studio, the user that created the
project will be automatically assigned to the tasks.

2.7

Option to check for tag ID mismatch

The Tag Verifier now includes a new option to Check for Tag ID Mismatch during QA Checks.
Use this to detect tag pairs with identical content that are labeled with different IDs in the
source and target segment. For certain legacy translation management systems, Tag ID
differences may affect TM matches and generate issues when the project files are opened.
Tag ID mismatch checks are typically not required in Trados Studio, Trados GroupShare or cloud
workflows.
To identify mismatching Tag IDs in your project files, go to Project Settings > Verification >
Tag Verifier > Common and enable the Check for Tag ID Mismatch option before running QA
checks.
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2.8

Support for Windows 11

Trados Studio 2021 SR2 offers full support for Windows 11, Microsoft’s latest operating system.
For more information about installing Trados Studio see Installing Trados Studio on page 37 or
check out the Installation Guide.

2.9

Early support for Microsoft Office 2021

Microsoft has recently released Office 2021. Since this new version does not include major
changes in the core structure of the files, you can open and work with Office 2021 files in Trados
Studio 2021. However, full support will be confirmed with a future Trados Studio update, once
we fully test all possible workflows.

2.10 Removed support for GroupShare 2015
Trados Studio 2021 SR2 introduces major improvements that are only supported by the TM
Service component that powers Trados GroupShare 2017 or later. As a result, users are no
longer able to use or log in to Trados GroupShare 2015 server. If you are still using Trados
GroupShare 2015, upgrade to a later version before installing Trados Studio 2021 SR2.

2.11 Performance enhancements
Improved batch edit operation for maintaining large server-based TMs
Trados Studio no longer times out when running batch edit operations even on large serverbased TMs. The new improvement allows you to maintain large server-based TMs more
effectively. Monitoring the operation in Trados GroupShare will become available in GroupShare
2021 SR1 Cumulative Update 6 tentatively planned for Q4 2021. Before that CU becomes
available, once the editing is complete, you can reopen the TM in the Translation Memories
view in Trados Studio and verify the results.

Improved and more robust processing of files that contain a large number of
embedded data elements
Trados Studio now processes such files significantly faster, more robustly and with less memory
consumption. (CRQ-18039)

2.12 Other enhancements
Support for cloud projects that use a pricing model without cost bands
Cumulative Update 8 for Trados Studio 2021 SR1 enhanced Trados Studio cloud compatibility for
cloud projects with custom cost bands.
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With the SR2 release, we are extending this support to cloud projects with pricing model that
don't include any cost bands. Cloud projects with no cost bands are supported when created
both from Trados Studio and Language Cloud.

Exposed Reports API
The Integration API now includes report management support. You can use the newly exposed
set of methods and events to build custom plug-ins around Trados Studio reports. For more
information see Working with Project Reports in the API documentation.

WebView2 package added to Studio installation wizard
The Trados Studio installer now includes Microsoft Edge WebView 2 as a package. This package
is a modern Edge-based web technology from Microsoft.
Trados Studio uses WebView 2 for the file Preview functionality, but also in other areas of the
application.

2.13 File Types and Core Components changes
This section contains an overview of changes and improvements brought to file types and core
components in this release.

General


Added emoji support for the following file types:


Microsoft Word and derivatives, such as Rich Text Format (RTF)



Microsoft PowerPoint



Microsoft Excel



PDF



Adobe InDesign IDML



Adobe FrameMaker MIF v2



XLIFF 1.2 & XLIFF 2.0



HTML, XHTML



XML



Text-based formats



RegEx



Tab & comma delimited text



Java Resources



PO



Subtitles
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YAML



JSON



Markdown



E-mail

Emoji support in other file types will come in a future update.


General performance improvements in processing embedded content.



Added safety checks to avoid "Null reference" errors when performing a batch search
in translation memories. (LCC-11851)



Encoded characters from hyperlinks in Word documents are no longer converted to
their original value. This prevents possible issues in terms of localizability and
adaptability and allows more freedom for regionalizing the URLs.



Excel files now feature safety checks for sheet names to prevent accidental changes or
errors caused by forbidden characters in the sheet name. (CRQ-23832)

Microsoft Word


Fixed a bug that blocked Trados Studio from extracting text from textboxes in files that
contained custom tags.(CRQ- 25162)



The layout of the elements was not kept in some target files, for example, a picture no
longer centered with the text. This was not a bug, but a settings misconfiguration. To
ensure the layout of your elements is preserved go to File > Options > File Types >
Microsoft Word 2007-2019 > Common and uncheck Skip advanced font formatting
(tracking, kerning, etc). (CRQ-25007)



Fixed an issue where pictures would not be visible in the target file. (CRQ-24794)



Fixed a bug that caused not-tracked spaces around track changes to be carried as track
changes in the target file when using a Right-To-Left language as target language.
(CRQ-24361)



Trados Studio would incorrectly add an extra space at the beginning of each paragraph
in RTL languages. The issue is now fixed and the target file is correctly generated.
(CRQ-24268)

MXLIFF


Mapped Memsource specific properties for forward and backward conversion.



Fixed "Null object reference" error when generating the preview. (LF-5412)



Fixed Preview corruption when target segment is empty. (LF-5440, LF-5350)



Added Internal and HTML preview for alternative translations. (LF-5355)
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XLIFF


Trados Studio now displays a message when there are no alternative translations for
preview (LF-5598)



Fixed "Null object reference" error that occurred in some files with custom tags. (CRQ25032)

HTML


Fixed an issue that displayed question marks (?) in the preview instead of the
translated content when working with Chinese as target language. (LF-5539, CRQ24392)

XML


Fixed issues that occurred in XML files when processing embedded CDATA with HTML 5
content processor. (CRQ-24946, CRQ-24950)



Fixed issue that caused "Null value" error when saving a Bilingual Excel file. (CRQ22870)



Fixed issue that caused "null value" error for the culture parameter when previewing
bilingual excel files. (CRQ-24781)

JSON


Fixed "Unknown character escape: \u" issue that occurred when trying to save the
target JSON files. (CRQ-24431)

MarkDown


Fixed issue when parsing image markup with specific link format, containing "%". (LF5499)

Subtitles


Trados Studio 2021 SR2 expands the Subtitles filter to include support for Timed Text
Markup Language (TTML). TTML is an XML-based standard for timed text in online
media, generally used as subtitles or captions.



Updated language attribute in target languages for *.VTT files. (LF-5455)

IDML


Fixed an issue that prevented Trados Studio from adding translated hyperlinks in the
target file if the hyperlinks were added on objects. (CRQ-24537)
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Fixed issues where Trados Studio would fail to save target content if the target file
contained missing closing tags. (CRQ-24415, CRQ-24496)

PowerPoint


Fixed a bug that caused an "Index out of bounds" error in *.PPTX files that contained
embedded Excel files with no title in the first column. (CRQ-24494)
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3

Issues resolved in Trados Studio 2021 SR2

This list details the issues that were resolved in the Trados Studio 2021 SR2 release

3.1

General resolved issues


Fixed script error that sometimes occurred after successful authentication to a
GroupShare server via SSO. (CRQ-22009)



Special characters in non-Latin script languages were displayed as square boxes in the
Editor view when using the Copy Source to Target option. This issue is now fixed.
(CRQ-23857)



When running an Analyze Files batch task on projects with source track changes
enabled, the Analyze report would incorrectly count track changes as Context Matches
instead of Fuzzy Matches. This issue is now fixed. (CRQ-24262)



Fixed issue where the Tag Verifier did not detect formatting tags inserted from a
different segment. Trados Studio now notifies you of any mismatching tag pairs, as
well as the operation that caused the mismatch, for example, addition or removal. To
identify mismatching Tag IDs in your project files, go to Project Settings > Verification
> Tag Verifier > Common and enable the Check for Tag ID Mismatch option before
running QA checks (CRQ-13763, CRQ-23833, CRQ-25075)



Fixed an issue with files not being added from folders when creating projects from the
Command Line. (CRQ-13779)



Fixed an issue where running Batch Edit tasks on large server-based TMs failed and
returned the "Exception in TM Service agent" error. (CRQ-16233)



Fixed an issue that caused the "constraint failed" error when running the Prepare
batch task on specific files. (CRQ-22804)



Fixed an error that occurred when opening a translatable file from a newly created
cloud project. (CRQ-25116)



Trados Studio no longer fails to start if there is a corrupt project file (.sdlproj) in the
project list. (CRQ-23941)



Fixed translation unit dialog box orientation for bi-directional languages. (CRQ-23894)



Fixed an issue that caused the "Object reference not set to an instance of an object"
error when running batch tasks. (CRQ-24384, CRQ-24372)



Trados Studio now correctly saves your hitlist settings from the Termbase Search tab
between restarts. (CRQ-24654)



Trados Studio now correctly applies Context Matches when the Show most recent
translations first option is enabled (CRQ-24953)



Fixed an issue that caused Thai segmentation rules to be changed even without any
modification when clicking Edit. (CRQ-22309)



Batch Delete function now works properly for large TMs. (CRQ-19024)
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Trados Studio would sometimes incorrectly add Context Match details when populating
project translation memories. This issue is now fixed. (CRQ-11295)



Creating projects in Studio using the command line failed if the file location path or the
document name contained space. This issue is now fixed. (CRQ-19023)



Fixed the "failed to retrieve cloud projects for the following accounts:" error that
occurred when trying to work with cloud projects created by deleted users. (CRQ23117)



When running a Batch Edit operation on server-based TMs to Find and Replace Text
with an empty Replace With string, Trados GroupShare would return a "Bad request"
response. This issue is fixed so you can replace text with empty strings during Batch
Edit operations. (CRQ-11313)



Publishing a project on GroupShare with LC Terminology termbase no longer corrupts
Mapped Languages in the LC Termbase project settings. (CRQ-14421)



Fixed a bug that caused the inconsistency check to not work correctly. (CRQ-24342)



Tracked deletions no longer count as missing translation in Trados Studio when using
the Verify Files batch task. (CRQ-24336)



Trados Studio would sometimes crash without displaying any error when adding a new
project template during project creation. This issue is now fixed. (CRQ-10947)



Fixed object reference issue that occurred when opening two virtually merged
SDLXLIFF files. (CRQ-11367)



It is now possible to use the AnyTM : Any file-based TM option on server projects as
an user without permission to edit project settings. TMs added through AnyTM option
are only stored locally and will be stripped from the project when publishing it to the
server. (CRQ-9312)



When working with Microsoft Visio files, Trados Studio would display a Could not load
file or assembly Aspose.Diagram error. This issue is now fixed. (CRQ-25029)



Improved character handling and Unicode processing which fixed a number of related
issues:


Chinese characters from CJK Unified Ideographs Extension B not being
recognized by Trados Studio. (CRQ-14903)



Unicode character 1D707 not being displayed in Trados Studio's Editor. (CRQ24735)



Special character "⎓" being invisible in source segment when the source
language is set to Chinese. (CRQ-24369)



Special characters shown as squares with non-Latin script languages as target
language. (CRQ-25104)



Characters encoded in the Private Use Area of Unicode being corrupted or
improperly displayed. (CRQ-24691)



Trados Studio's Editor not being able to extract and render emojis. (CRQ-6257)
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Known issues

This section lists the limitations associated with the 2021 SR2 release of Trados Studio.

4.1

General known issues

Trados Essential: Tasks not auto-accepted after revert
Trados Live Essential subscriptions offer a simple translation workflow for working with cloud
projects. This workflow does not include a Review task, but enables you to revert any Completed
tasks back to the Translation stage. Revert Translation tasks to make further changes to a
completed translation, similarly to how you would update a translated file following a Review
task.
With Trados Essential, Translation tasks are always assigned to you, and automatically accepted
for your because you are the only user working on your project tasks. However, with this initial
release you need to manually accept the new Translation task created automatically following
the task reversal. To accept reverted tasks:


from Trados Studio: double-click on a Completed task from the Files view and confirm
that you want to revert the status and continue with the translation.



from a browser: go to the Inbox tab > New, select the completed target file and click
Accept. Accepted tasks show up in the Active tab from where you can open them in
Studio or in the Online Editor.

Placeables containing formatting tags are not identified correctly
Trados Studio detects any formatting differences inside numbers, dates and other placeables in
the source text. These differences introduce formatting tags that split up the token, thus
affecting match recognition and auto-localization. Formatting differences inside placeables can
occur especially with non-alphabetic languages, like Japanese. For these languages, text editors
may apply mixed formatting to strings made up of language-specific character sets and
alphanumeric letters.
To work around this issue, check your source document for formatting differences inside the
elements that Studio treats as placeables:


Dates



Times



Numbers (in numerals)



Measurements



Acronyms and URLs



Email addresses



Alphanumeric strings



Variables
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Currencies

Previous Trados Studio versions do not fully support the new TQA category during TQA
batch task
Trados Studio 2021 introduces a new TQA category: Not Categorized. This default category in
2021 is not recognized in previous Trados Studio versions and is automatically converted to
CategoryNotSet.
When running TQA batch tasks on 2021 projects that include the new Not Categorized TQA
category, Trados Studio 2019 and earlier show the following error message: "Unexpected
exception when completing task Translation Quality Assessment: Object reference not set
to an instance of an object."
To work around this issue, manually assign all your CategoryNotSet/Not Categorized TQA
items on of the other TQA categories in your configuration. To do this, open your project files in
the Editor view and check your 2021 TQA items in the TQAs window. To avoid compatibility
issues, we recommend using TQA configurations created in Trados Studio 2021 only with the
current and future Trados Studio releases.

Some UI elements not localized after switching language
When choosing a different user interface language and restarting Trados Studio, some of the
user interface elements may not show the new language as expected. When this happens, click
View > Reset Window Layout to refresh the user interface and show all elements localized.

The TQA window stays open the Editor view
The TQA window reopens automatically after restarting the Editor view. Close the window
manually until this issue will be fixed in a future release.

Cannot select project templates while another project is being prepared
You cannot select a new project template for your projects while Trados Studio prepares
another project.

4.2

Save to Cloud limitations

Save to Cloud does not support all project and package formats


You cannot save the following to cloud:


local projects that contain physically merged files. (LG-30309)



local projects that are a single file opened for translation using the ,,Translate
Single Document" option
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WorldServer and TMS packages. Saving these projects to cloud will become
available in a future update.

Saving project packages to cloud requires the native files to work correctly
To correctly save packages to the cloud, Trados Studio requires the native files of each target
bilingual file. However, the native files may not be available if the package was created in
Trados Studio 2021 SR1 and earlier, when source files that were too large to be included in the
package were embedded in the .SDLXLIFF files or added as separate dependency files. If the
project package you are trying to save to cloud includes:


Embedded files - you can save to cloud, preview and generate the target files. This is
because Trados Studio 2021 SR2 automatically extracts the native files from embedded
files.



Linked dependency files - you cannot preview or generate target files. The package
can be saved to cloud only if the linked files are .docx, .pptx, .xlsx or .PDF 3.0.0.0
documents.

Packages without native files, embedded content or that contain other type of linked
dependency files cannot be saved to cloud, unless the project packages are based on a .txt file.
If you are creating packages in Trados Studio 2021 SR1 or earlier, make sure to increase the
maximum embedded file size for native files in order to save these packages to cloud.
To increase the maximum embedded file size, go to File > Options > File Types > SDL XLIFF >
General and drag the slider to the max.

Return packages must be created from the same instance of Trados Studio that saved
the package to cloud
When working with project packages saved to cloud, you can only create a return package from
the same instance of Trados Studio that saved the package to cloud.

Packages saved to cloud lose their attributes if they are removed from the project list
If you remove a project package saved to cloud from the project list, and then download it
again, it will lose its project package attributes and become a cloud project instead.

Cloud project settings take priority over local project settings
When saving projects to cloud, cloud project settings take precedence over your local project
settings. This means that your cloud project will use default cloud project settings. Support for
specifying a cloud project template or saving your local project settings to cloud will become
available in future updates. After the project has been saved to cloud, you can change the
project settings in the browser at any time and they will also be synchronized back to the Studio
project.
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Translation Engine matches may overwrite existing confirmed segments
When you save a project to cloud that includes confirmed translations, the matches coming
from your translation engine may overwrite any unlocked segments. To avoid this, lock
translated segments that you want to keep before saving local projects or packages to cloud.
For instance, if you use PerfectMatch, segments will be locked by default, and segment content
will remain unchanged.
Alternatively, Trados Live Team and Trados Enterprise users can adjust the workflows used for
saving projects to cloud, to exclude automated translation and translation memory matching as
desired.
A future update to Trados Studio will give you more fine-grained control over this behavior

Reference files not imported with the cloud project package
Any reference files included in offline cloud project packages are not visible when opening the
package in Trados Studio.

4.3

Known issues for cloud projects

Cannot run local batch tasks on remote cloud files
You only run batch tasks on cloud files that are downloaded in Trados Studio and available on
your computer. Open cloud files in the Editor view to bring them in Trados Studio where you
can then run batch tasks locally.

Local batch tasks do not check cloud translation engines
By design, it is not possible to use cloud translation engines when running batch tasks on local
projects. Cloud engines are applied during pre-processing cloud projects, so it is recommended
to create cloud projects or save local projects to cloud to enable batch processing.
This means, for instance, that the Analyze Files batch task will not reflect correct numbers if you
run it from Trados Studio. Nor will the Pre-translate batch task apply any results from cloudbased translation memories, as this already happened in pre-processing.
As best practice, we recommend the following:


Use the new Save to Cloud functionality for local projects. This combines the best of
both worlds: you can prepare the files locally and then move them easily to the cloud
for running batch processing against translation engines and sharing all resources with
your team.



For any projects that you wish to keep local, use the WIP Report, Translation or Word
Count batch tasks in Trados Studio. These batch tasks can always be run locally and
give you an accurate overview of the work required for your current file or the project
as a whole.
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5

Changes introduced in Trados Studio 2021 SR1

This release updates Trados Studio with improvements in the way you can work with termbases
and cloud projects, and introduces a new way of inserting tags which can help you format your
translations faster. The product documentation also includes an update to the localized Online
Help and PDFs.

5.1

Place tags automatically with Auto-Insert Tags

Trados Studio can now automatically transfer tags from the source segment and place them at
the right position in the target segment.
The new Auto-Insert Tags option enables you to insert formatting and any other missing tag
pairs from the source in just one click. This can greatly enhance your productivity as you no
longer need to copy tags, use the QuickPlace menu (CTRL + ,) or set up custom QuickInsert
items.

After manually translating a segment in the Editor view, right-click and select
AutoInsert Tags to transfer missing source tags. The option is also available from the Advanced
tab and from the Home tab > QuickInsert group. Default keyboard shortcut:
Ctrl+Alt+Insert.
To make sure Auto-Insert Tags "understands" where to place the target tags:


use a file-based project translation memory (TM) with at least 1000 translation units.



turn on Fragment Alignment in your TM settings.

For more information, see Placing tags using Auto-Insert Tags.

5.2

Enhanced integration with MultiTerm

Trados Studio 2021 SR1 includes key MultiTerm enhancements to make adding and editing of
termbase entries much easier and faster.

Access picklist items easier
When adding or editing termbase entries from the MultiTerm Termbase Viewer, you can now
use the keyboard also for adding and navigating through picklist field values. Additionally, you
can search within picklists by typing the first letters of the picklist value. Searching as-you-type
makes it easier to filter long picklists:
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To enable keyboard navigation inside termbase entries, enable
the Tembase Viewer window > Default layout.

Enhanced Editing Mode in

Add terms faster
When you add new termbase entries from the Editor view > Add New Term, the Termbase
Viewer window now displays without flickering, and enables you to scroll through the terms in
the Browse list with ease.

5.3

Enhanced integration with Language Cloud Terminology

We have enhanced the Language Cloud Terminology functionality to bring more search
flexibility and to improve terminology recognition when working with cloud termbases from
Trados Studio.

Aligned Term Search settings for cloud and MultiTerm termbases
Cloud termbases now give you access to all the search settings that you are used to from filebased and server-based termbases.
The Terminology Settings includes three new options, copied over from the Search Settings
page:


Show recognized terms with no available translation



Enable recognition of two-letter terms



Allow overlapping terms

This parity of settings enables to query all project termbases similarly, and generate better
results for term searches that include cloud termbases.
Synchronize the term search settings
Make sure to set the same term search settings for and cloud termbases. If you specify different
term search settings, the settings for termbases will take precedence.
To synchronize the term search settings across cloud and termbases:
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1. Open your project and click Project Settings > Language Pairs > All Language Pairs >
Termbases. If you want to specify termbase search settings for all future projects
instead, go to File > Options > Language Pairs > All Language Pairs > Termbases.
2. On the Termbases page, go to Use >SDL Language Cloud Terminology and click
Settings. Enable your cloud termbase and specify the settings for the last three Term
Search recognition options at the bottom of the page. Click OK to close the SDL
Language Cloud Terminology window.
3. Back in the Termbases tree, select the Search Settings node and make sure to define
the same Search Settings for file-based and server-based termbases.

More accurate term recognition
Language Cloud Terminology includes several robustness enhancements that translate into
better term search results and less false positive matches for all tembase languages.

5.4

Cloud projects enhancements

Trados Studio 2021 SR1 includes a set of enhancements to improve your productivity when
working with cloud projects:

Access to cloud linguistic resources from cloud packages
Project managers can export cloud projects from a browser to send work to translators and
reviewers who do not have access to the online cloud environment.
In addition to the bilingual .SDLXLIFF files, these project packages can now also include the
project translation memories (TMs) and project termbases. Offline access to cloud resources
enables offline team members to work with cloud projects better.
The return packages created from only contain the updated bilingual files. Project managers
upload these back into the cloud account to finalize the mixed online/offline workflow.
Compatibility
Cloud translation packages can be opened in Trados Studio 2017 and later. Termbases in offline
cloud projects are accessible only from Trados Studio 2021 and later.

Improved synchronisation of cloud project settings
Trados Studio can now recognize the QA Checker and Tag Verifier settings defined for cloud
projects. These settings are read-only in Trados Studio and can be further edited from your
cloud account.

Option to show projects from current account only
Trados Studio enables you to connect to multiple cloud accounts and displays all the projects
available for you on these accounts.
If this clutters your Projects list, you now have the option to Show projects from current
account only and filter out the projects that you are not currently working on.
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Resource location displayed in the Create New Cloud Project wizard
When creating new cloud projects, you can now also see the location of the resources that are
available for adding to the new project. This enhanced labeling makes it easier to distinguish
between resources with the same name that may be available at different locations in your
cloud account:

5.5

Localized documentation

The online Help and the Quick Start Guides for Trados Studio 2021 are now also available in the
following languages:


Chinese



French



German



Japanese



Spanish

You can access this documentation from the Trados Studio user interface and from the
Documentation Centre.

6

Issue resolved in Trados Studio 2021 SR1

This list details the issues that were resolved in the Trados Studio 2021 SR1 release:

6.1

General resolved issues


Languages in cloud termbases not mapped automatically. (LG-24959)
Trados Studio can now correctly map the language pairs of a cloud termbase to the
languages of the downloaded cloud project. This means that you no longer get an
error message when translating cloud project segments for which termbase results are
available.



Offline deactivation code truncated in the Product Activation window. (LG-25195)
Trados Studio now inserts the complete deactivation code when pasting it using the
context menu or the CTRL + V shortcut.



New terms added to first cloud termbase, regardless of language pair. (LG- 25742)
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Trados Studio no longer adds new entries to the first termbase available in the
attached translation engine. Instead, it first filters out the termbases that do match the
language pair of the current project file. This ensures that new terms are added to the
first relevant cloud termbase in your cloud translation engine.


[Localization]'Sign Out' text from 'Contact your LC admin' page is trimmed in French
and Spanish UI. (LG-25235)
"Sign Out" text from "Contact your LC admin" page is now fully visible for the French
and Spanish UI.



Locked segments number is not displayed in Trados Studio. (LG-24839)



Wrong language pair for POST /translations/v2/translate. (LG-23117)
Fixed error that occurred when retrieving translation results from neural machine
translation providers in projects with language variants.



Fixed error that occurred when retrieving translation results from neural machine
translation providers in projects with language variants.
Fixed issue where users got the following error message "Termbase [id] is not available
any more" which is no longer displayed when using Language Cloud termbases with
revoked or expired sharing links



Link for "Trouble Signing in" - Language Cloud not pointing to an available article. (LG18541)
The link for "Trouble Signing in" on the Language Cloud sign-in page is now pointing
to an available article.



If GroupShare Organization name contains a plus sign (+) or ampersand (&),
Translation Memories are not selectable/visible anymore in Trados Studio. (CRQ-19978)
Fixed issue where Translation Memories are now visible and usable when using
GroupShare Organization names that contain a plus sign (+) or ampersand (&) in
Studio.



Missing Ribbon Icons part of Advanced tab. (CRQ-19234)
Fixed issue where the icons in the Advanced tab are visible also if the segment is
empty.



Standard XLIFF Filter disappears form the list of file types after extension plug-in is
loaded. (CRQ-19171)
Fixed an issue where loading a custom XLIFF file type would cause the standard XLIFF
file type to no longer be available after restarting Studio.



"The requested data file could not be located" error when deleting from disk a TM
opened in TM view. (CRQ-17128)
Fixed an issue where an error occurs in Translation Memory and Automated
Translation tab in Project Settings if the attached local translation memory is deleted
from the disk or it could not be found. A friendly message is now shown and the
translation memory is then removed from the list.
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Fixed an issue where an error occurs in Translation Memory and Automated
Translation tab in Project Settings if the attached local translation memory is deleted
from the disk or it could not be found. A friendly message is now shown and the
translation memory is then removed from the list.



GroupShare Project Resource Libraries are visible in Trados Studio. (CRQ-16482)
Fixed an issue where dynamic resources were displayed under "Filter" rather than
displaying only organizations and project resources while interacting with server-based
GroupShare translation memories



Match Value score disappears from the Segment Status Column. (CRQ-15523)
Fixed an issue where translation results match values coming from aligned translation
unit would disappear if the target segment is edited.



Term recognition fails when there are no spaces in between tags or between tags and
terms. (CRQ-12970)
Fixed an issue where no terms are retrieved for term recognition in Studio if there is no
space between tags or between tags and terms.



Alignment: Error message when Aligning Multiple Files 'The method or operation is not
implemented'. (CRQ-12724)
The intermittent error 'The method or operation is not implemented' no longer occurs
when attempting to align files from multiple folders.



Missing localization for header of "Advanced Display Filter" window. (CRQ-12460)
Added localization for "Advanced Display Filter" window header.



Confirm and Translate until Next Fuzzy Match command in Studio 2017 SR1 and Studio
2019 SR2 not working as expected. (CRQ-8901)
The Confirm and Translate until Next Fuzzy Match operation has been changed to stop
on confirmed segments when the TM returns an exact match with applied penalties
(e.g. multiple translation penalty). All the existing rules for deciding when to stop the
translate to fuzzy operation have not been changed.



Connection to server TM lost after 12 hours: An error has occurred whilst using the
translation provider [TM_Name]: One or more errors occurred. (CRQ-10873)
Fixed connection issue to GroupShare translation memories being lost after 12 hours.



Target comment on segment level is not preserved when applying TM or copying
source. (CRQ-14276)
Fixed issue for not preserving comments at target segment level after applying
translation results or by copying source to target. The Clear Target command will still
delete such comments by design.



Custom file type added under "Additional installed File Types exist" after each restart
of Trados Studio. (CRQ-18946)
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After selecting a custom file type from "Additional installed file types exist" there are
correctly added and persisted to the File Types list and no warning is displayed to the
page.


Auth0 login authentication keeps only one GroupShare server connection at a time.
(CRQ-19336)
Fixed issue when using multiple GroupShare server connections via Auth0 provider
Studio would keep only one single connection alive. From now on users are kept
logged in for each GroupShare server connection instance.



Auto-substitution dates and times has no defaults when using LC TMs. (LG-25672)
Fixed dates and times auto-substitution not returning default values for Language
Cloud translation engines containing translation memories.



[LC Project]: The notification messages are not removed when switching from Files
view to the Editor. (LG-24450)
The displayed notifications for available files in Studio when accepting new tasks for a
Language Cloud project are now cleared when opening the downloaded files using all
"Open in Editor" mechanisms.



[New project] Error displayed when trying to create new local projects with large files
from Welcome view. (LG-25851)
Fixed an issue where local projects could not be created from Welcome view when
using large files (files larger than ~20MB).



[LC Project]: Enhancement - The location is not displayed in Studio for resources from
Language Cloud. (LG-24557)
Enhanced resources available in the new Language Cloud project wizard by displaying
their locations under each resource. Change available for the following resources:
Project templates, File type configurations, Translation engines, Pricing models,
Workflow models.

6.2

Resolved File Type issues


[HTML, XML]: Lost focus at scrolling when prioritizing and de-prioritizing parser rule.
(LF-5325)
Fixed an issue regarding losing focus when prioritizing or de-prioritizing parser rules,
by scrolling to the correct position in order to be visible in the Parser section for XML
and HTML from the Options window.



[HTML]: Next button not working over parser rules list. (LF-5324)
Next button working as expected for parser rules in HTML filter page from Options
window.



[Xliff 2] Change the resegmentation logic to match the specs. (LF-5323)
Improved resegmentation logic for XLIFF 2 to increase performance.
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[FrameMaker 10.*] Write corresponding escape sequence when a non-breaking space
character is introduced in variables and references. (LF-5321)
Addressed community feedback idea regarding FrameMaker 10 filter to correctly
handle escape sequence when a non-breaking space character is available in variables
and references.



HTML: Translatable property for attributes issues with conditions. (LF-5310)
Addressed community feedback issue for HTML parser rules for sharing translate
property attributes in two segmentation rules with the same element name.



[Xml1, Xml2 Dita preview] Change how the dita2html xsl is loaded. (LF-5306)
Added new option in DITA preview giving users the option to decide which type of
transformation to be used in order to load the preview faster. Users can now choose
between built-in transformation or DITA toolkit specified by the user.



[Photoshop]: Fonts are lost after round-trips with Aspose. (LF-5301)
Fixed issue for Photoshop filter in which fonts were lost after round-trips.



Improve whitespace normalization in XLIFF 2.0. (LF-5295)
Improved the whitespace normalization in XLIFF 2.0.



[Visio] Html preview. (LF-5215)
Added HTML preview for Visio filter.



Add support for the css-style attribute. (LF-5178)
Added support for css-style attribute in XLIFF 1.2 filter.



Support merging comments over multiple segments in DOCX. (LF-5157)
Fixed community idea for comments spanning multiple segments in the same
paragraph.



Support segmentation in PO for sections with empty msgstr. ( LF-5156)
Added support for segmentation in portable object file type to support empty msgstr.



Review handling of invalid HTML/XML files. (LF-5155)
Added warnings or errors if the HTML parser detects "partial" HTML tags.



Improve creation of parser rules. (LF-5154)
Improved creation of parser rules by being able to select multiple entries/tags and to
import additional files after a parser was created so that adding entries/tags are easier



Change display text for footnotes. (LF-5153)
Fixed issue by displaying the number of the footnote instead of the the TagID in the
document for Microsoft Word documents.



Review handling of inline Code element in HTML. (LF-5152)
Fixed issue by changing the default segmentation hint from "May exclude" to
"Include".
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Improve HTML preview based on feedback. (LF-5145)
Improved HTML preview by changing the scrolling with word wrap to avoid lateral
scrolling.



Add new options for JSON parser rules. (LF-5141)
A new option for JSON parser rules was added, to extract certain values from a specific
path. (CRQ-19352)



Optimised 'batch' import flow can fail to align placeables. (LCC-10772)
Fixed issue when using optimised batch import flow failed the TUs to be tokenized.
Ensure TUs are always tokenized with bundle support before segment hashes are
generated.



Optimise file-based TM import. ( LCC-10708)
Optimized file-based TM import. This also prepares future enhancements around
server-based TM imports.



DOCX: Failed to save target content: The XPath expression evaluated to unexpected
type System. Xml.Linq.XAttribute. (CRQ-21340)
Fixed issue when trying to save a .docx with content control in footer failed with the
following message: "Failed to save target content: The XPath expression evaluated to
unexpected type System. Xml.Linq.XAttribute."



MIF V2 generates "Value of '-254999745' is not valid for 'red'" error when trying to
open a mif file in Studio 2021 CU1. (CRQ-21321)
Fixed issue when using a MIF V2 filter in Studio, files can not be processed and "Value
of '-254999745' is not valid for 'red'. 'red' should be greater than or equal to 0 and less
than or equal to 255" error occurs.



XLSX: The document cannot be processed since it contains unexpected contents. (CRQ21271)
Fixed issue that was causing the following error message when creating a project when
using .xlsx files "The document cannot be processed since it contains unexpected
contents".



JSON: "Object Reference Not Set ..." error message when using the "Generate Target
Translation". (CRQ-21242)
A specific error message is displayed now when using a source file that has a
duplicated key in the root object instead of the error message "Failed to save target
content: Object reference not set to an instance of an object".



JSON file segments are extracted based on the order of the rules instead of the text
position in the file. (CRQ-20977)
JSON file segments are now extracted based on the order of the text position in the file
instead of the order of the rules.



Custom XML: Segmentation not working correctly when segmentation hint is set to
"Exclude" for ph tag. (CRQ-20123)
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Fixed issue when segmentation hint for a self-closing tag (ph) was set to "Exclude" was
not working correctly and the text following this tag is moved outside of the segments.


Segmentation: Studio doesn't segment at semicolon (while using the default Hebrew
segmentation rules). (CRQ-19391)
Fixed issue in Studio when using default Hebrew segmentation rules.



Trados Studio: Softbreak segmentation rule causes "The document cannot be
processed since it contains unexpected contents." (CRQ-19320)
Fixed issue that was causing the following error message when creating a project using
.docx files with specific segmentation rules "The document cannot be processed since
it contains unexpected contents".



Project creation fails with the error "The document cannot be processed since it
contains unexpected contents" when using .docx file containing character formatting
and TM with custom segmentation rule. (CRQ-18959)
Fixed issue that was causing the following error message when creating a project using
.docx files containing character formatting and TM with custom segmentation rule"The
document cannot be processed since it contains unexpected contents"



DOCX: Text with tracked changes extracted between segments. (CRQ-18751)
Fixed issue where segments where incorrectly split when using Word 2007-2019 filter
with "Apply Track Changes before opening".



Trados Studio 2019: The document cannot be processed since it contains unexpected
contents. (CRQ-18583)
Fixed issue that was causing the following error message when creating a new project
using custom Regular Expression Delimited Text Document file type filter "The
document cannot be processed since it contains unexpected contents".



IDML: tblref is extracted as inline instead of structure tag. (CRQ-18465)
Changed the segmentation into a tblref placeholder to be May-Exclude instead of the
old Includewithtext.



Unnecessary multiple translations after enabling recognition of alphanumeric strings.
(CRQ-5475)
Multiple translation units are no longer created unnecessarily after enabling the
recognition of alphanumeric strings.
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7

Changes introduced in Trados Studio 2021

This section contains the list of new features and functionality that were introduced with the
Trados Studio 2021 release.

7.1

Create and work with translation projects in the cloud

Starting with this release, you can upload your projects, translation memories and termbases
into your own secure cloud space and use them in Trados Studio, along with neural machine
translation. With cloud projects, you enjoy the security of knowing that your work is synced to
the cloud all the time and your projects are backed up in a secure environment.

Language Cloud accounts and cloud subscriptions
Cloud projects and resources are saved and synced to Language Cloud, the innovative
translation productivity cloud from RWS. You can create and access cloud projects with a
Language Cloud account and an active subscription for one of the following cloud offerings:


Trados Enterprise (formerly Language Cloud Translation Management)



Trados Live Team



Trados Live Essential

With a Trados Live Team and Trados Enterprise subscription, you can also share your cloud
projects and translation resources with other team members to optimize teamwork.

Benefits of cloud projects


Work anywhere, anytime. Create and get projects moving even when you are on the
go. Cloud projects are available online, so you can access them wherever you work
from.



Work from any device. You can create and access cloud projects from a PC, laptop,
tablet, smart phone, or from a MAC through a browser. For example, you may prepare
a project on your phone, review translations from your tablet, and plug in Trados
Studio to do the heavy work on your desktop.



Access to the Online Editor. The Online Editor is a powerful online editing
environment with enhanced commenting, tracked changes and online review
capabilities. Use it as a companion to Trados Studio for translating and reviewing cloud
project files from a browser.



Access to the Trados Live app. Start projects, view statistics, accept new tasks and
keep up to date with project progress wherever you are - directly from your mobile
phone.



Blend online and offline working. Any offline changes made to cloud files in Trados
Studio are synced to the cloud as soon as you get back online.



Collaborate on projects with shared resources. Sharing in the cloud is available with
a Trados Live Team or Trados Enterprise subscription.
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Easy overview of projects. The Dashboard in your cloud account enables you to
monitor and analyze all your cloud projects.



Better backup. RWS's secure cloud storage system is the safest place to store
translation projects and resources. You will no longer have to back up your projects on
USB sticks or third-party data storage systems.



Better performance. The processing of cloud project files is handled in the cloud. This
means that Trados Studio can keep all its available resources for your local projects

Get started with cloud projects
Click
in the upper-right hand corner and log in to your Language Cloud account with
your RWS ID. Go to the Projects view and click New > New Cloud Project.
Watch the How to work with cloud projects video to learn how to create and work with
translation projects in the cloud. For more information, see Working with cloud projects in the
online Help.

7.2

Subscription-based licensing

Starting with this release, you can also activate Trados Studio with an annual subscription.
Subscriptions enable you to access Trados Studio with Language Cloud or Trados Live benefits
Subscriptions are linked to Language Cloud accounts. You can connect to a Language Cloud
account using your RWS ID email address. Each Language Cloud account enables a specific
number of users to activate Trados Studio and use specific Language Cloud or Trados Live
resources.

Subscriptions benefits
A Trados Studio subscription provides an alternative to permanent licenses and includes a
Trados Live Essential subscription with the following benefits:


access to cloud projects



lower entry price and the ability to pay-as-you-go



receive first all the latest features, fixes and security updates

Subscription plans
The following subscriptions are available to meet the different needs of freelance translators,
Language Service Providers and corporate or government customers:
Subscription name

Includes

Trados Studio Freelance

Access to Trados Live Essential Freelance

Trados Studio Professional

Access to Trados Live Essential Professional
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Perpetual licenses
The following perpetual licenses are available to meet the different needs of freelance
translators, Language Service Providers and corporate or government customers:
Product name

Includes

Trados Studio 2021 Freelance

Free 12 months subscription to Trados Live
Essential Freelance

Trados Studio 2021 Freelance Plus

Free 12 months subscription to Trados Live
Essential Freelance

Trados Studio 2021 Professional

Free 12 months subscription to Trados Live
Essential Professional

Trados Studio 2021 Professional Network

Free 12 months subscription to Trados Live
Essential Professional with one Trados Live
subscription for every network license

Note: Existing perpetual licenses remain valid and are not impacted by the added subscription
licensing model.

7.3

Custom auto-localization formats

Starting with this release, you can extend the formats that Trados Studio uses for identifying
and auto-localizing the following recognized tokens (also called placeables): dates, times,
numbers, measurements and currency amounts.
The default Trados Studio settings ensure that all recognized tokens are correctly identified and
localized according to the specifications of each target language. However, when working with
non-standard documents, you might want more control over what Trados Studio considers nontranslatable elements and how it localizes them during translation. Specify and prioritize your
own patterns so that Trados Studio can use them when generating QuickPlace and Automatic
Translation (AT) suggestions and when auto-substituting values in TM matches.
For more information, see Default auto-localization formats and Customizing auto-localization
formats.

7.4

Enhanced Advanced Display Filter

The Advanced Display Filter has been updated and renamed to Advanced Display Filter 2.0 to
illustrate the major improvements it contains. This new version builds on the popular
Community Advanced Display Filter app to provide more powerful search criteria for filtering
segments in the Editor view.
In addition to the existing search functionality you can now also:


Reverse searches



Highlight filtered segments



Export the list of filtered segments for later reuse



Search inside comments using regular expressions

31



Filter by additional criteria:


on all unique occurrences of segments, and not just repetitions



on specific segments by their segment number • on merged segments only,
including segments merged over hard breaks



on segments where the source equals target, including case differences



by fuzzy match value



by the color of the text in the source and/or target segments



by the color of the highlighting in the source and/or target segments



by segments containing tags



by content inside tags



by random segments for QA checking

For more information about working with the new Advanced Display Filter 2.0, see Applying the
Advanced Display Filter and Specifying regular expressions for the Advanced Display Filter.

7.5

Optimized TQA functionality and user experience

To streamline the workflow of evaluating translations, the Translation Quality Assessment (TQA)
feature includes the following set of improvements:


Enhanced TQAs window to quickly edit TQA items inline and toggle TQA mode ON/OFF.



Improved flow for capturing TQAs: first review segments, then assign TQA information
(category, severity, type, comments).



Removed prompts for mandatory TQA information after making segment changes.



Possibility to bulk-edit TQA items by applying TQA information to multiple TQA changes
in one go.



Added default TQA information: Category - Uncategorized, Severity - None, Penalty 0. This default configuration can also be useful for marking error repetitions without
applying further penalties.



Added Replacement edit type to indicate a coordinated TQA text Deletion and
Insertion.



Various bug fixes to improve the overall TQA functionality.

Backwards compatibility
The new TQA information introduced in this release is not fully supported in previous versions
of Trados Studio. To avoid compatibility issues, we recommend using TQA configurations
created in Trados Studio 2021 only with the current and future Trados Studio releases.
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7.6

Fully integrated RWS AppStore with support for private distribution

The RWS AppStore is now built directly into Trados Studio. This integration gives you easier
access to a multitude of plug-ins that customize Trados Studio to extend its capabilities.
The RWS AppStore button on the Add-ins tab no longer points to the web version of the store.
Instead, it launches a full-fledged, Trados Studio version of the RWS AppStore. This enables you
to discover, install and manage apps without leaving Trados Studio.

Private distribution option
You can also use the new, integrated RWS AppStore to host public and custom Trados Studio
apps specifically for your organization. With private distribution you can create your own,
private hosted version of the RWS AppStore, and distribute internally the apps that you approve
for users in your organization.

7.7

Possibility to import and export language resources

To handle bulk transfer of language resources to and from a TM or TM template, Trados Studio
now offers an Import/Export option for list of abbreviations, ordinal followers and variables.
The new Import and Export all options are available when editing any of these three language
resources in the Translation Memory view > Translation Memory Settings or Language
Resource Template Settings page.
To import your existing lists of language resources, create a text file with one item per line. You
will need a separate import file for each language resource type: variables, abbreviations and
ordinal followers.
For more information, see Importing and exporting TM language resources.

7.8

Relaxed language restrictions for Freelance version

Trados Studio Freelance is no longer limited to five available source and target languages.
Instead, you can open, translate and create projects in any language. Any new multilingual
projects that you create can include up to three target languages.
If you need to use more than three target languages, create separate projects.

7.9

Dedicated apps for working with WorldServer projects and legacy file
types

We have migrated support for WorldServer and legacy Trados file types to dedicated apps
available from Trados Studio. The apps install as add-ons to Trados Studio and enable you to
open and work with projects and packages that include these types of bilingual files.
To install the apps, go to the Add-Ins tab > RWS AppStore and search for the following apps:

Trados Compatibility and Migration Power Pack
Install this app to add support for the following common compatibility and migration scenarios:
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Open legacy SDLX/ITD-based TMS and TeamWorks project packages.



Open ITD, TTX and Bilingual Workbench file types created in SDLX, Trados 2007 and
Translator's Workbench. Official support for these products has ended in 2012. RWS
recommends that you consider converting these legacy file types to the .SDLXLIFF
format.



Add the Upgrade Migration Wizard to Trados Studio. This wizard was available out-ofthe box with previous Trados Studio versions, but has now moved to this dedicated app
in order to declutter the Trados Studio user interface. This powerful wizard enables the
following batch-oriented use cases:


Combine multiple Trados Studio translation memories (TMs) into one



Upgrade Translator's Workbench and SDLX TMs to Trados Studio translation
memory format: .TMW and .MDB format to .SDLTM



Migrate TMs from TMX to Trados Studio format in batch mode



Migrate file-based to server-based TMs in Trados GroupShare and vice versa

WorldServer Compatibility Pack for Studio
Install this app to work with WorldServer bilingual files and packages, including Live TM
connections, created in WorldServer 11.x and 10.4.5. For more information about the working
with these apps, check their descriptions in the RWS AppStore.
You can also access the RWS AppStore from a browser.

7.10 Extended keyboard support in the Editor view
We have added new keyboard shortcut to help you increase your productivity when working in
the Editor view.
Go to File > Options > Keyboard shortcuts and set your preferred shortcuts for the following
new available actions:
New available
shortcut

Description

Further available action

Translation
Results

Moves the focus from the Editor view
to the Translation Results window.

Use the ↑ Up and ↓ Down arrows to navigate lineby-line through the translation memory matches.

From here, you can select results from
lookups in your active translation
memory or draft translations from
automated translation servers.

To insert the selected match in the active segment,
press your specified shortcut for Apply Translation
Result. The default shortcut for this is CTRL+T.

Moves the focus from the Editor view
to the Fragment Matches window.

Use the ↑ Up and Down ↓ arrows to navigate
between fragment match results.

From here, you can select fragment
match results from lookups from your
active translation memory or
automated translation server.

Press your specified shortcut for Apply Fragment
Match Result or the default CTRL+ALT+M to insert
the selected fragment match result into your
active segment.

Moves the focus from the Editor view
to the Term Recognition window.

Use the ↑ Up and Down ↓ arrows to navigate
between termbase results.

Fragment
Matches

Term Recognition
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Termbase Search

From here, you can select term
matches that Trados Studio identified
automatically in your active termbase.

Press Insert to insert the selected termbase entry
into your active segment.

Moves the focus from the Editor view
to the Termbase Search window.

Press Tab to move from the search box to the list
of search results.

From here, you can manually search
for entries in your active from your
active termbase.

Use the ↑ Up and Down ↓ arrows to navigate
between results.

Press Enter to open the Termbase Viewer window
and see more details about the termbase entry.

Press Insert to insert the selected termbase entry
into your active segment.
Press Enter to open the Termbase Viewer window
and see more details about the termbase entry.

Concordance
Search

Moves the focus from the Editor view
to the Concordance Search window.

Press Tab to move from the search box to the list
of search results.

From here, you can run concordance
searches in the active translation
memory. Concordance searching tries
to match parts of the selected text or
segment even if the words appear in a
different context or order in the TM
segment.

Use the ↑ Up and ↓ Down arrows to navigate
through the results line-by-line.
Select the relevant text from the segment result
and press CTRL+ALT+F3 to insert the selected text
into the active segment.
Press your specified shortcut for Clear
Concordance Search to clear the search results.
Press F3 to generate a new search after selecting
segment text.

TQAs

Moves the focus from the Editor view
to the TQAs window.
From here, you can:

View translation quality
assessments (TQAs)
available in the files open in
the Editor view.



Add, edit and delete TQAs
available in the files that are
open in the Editor view.

Use the ↑ Up and Down ↓ arrows to navigate
between results. Select a result and press:

Ctrl+Shift+E to edit TQA result.

F9 to move to next TQA item.

Shift+F9 to move to the previous TQA
item.



Ctrl+Shift+Q to delete the selected TQA
item.
To add new TQA items, select some segment
text from the Editor window and press
Ctrl+Shift+T.

Return focus to the last active segment
To move the focus back to the Editor view, and place the cursor in the last active segment, click
CTRL+0. You can change this default key shortcut combination from File >Options > Keyboard
shortcuts > Focus Editor window.

7.11 Community Inside app bundled with Trados Studio
Starting with this release, you can access even more Help resources from within Trados Studio.
The new SDL Forums option on the Help tab opens up Community Inside app in Trados Studio.
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From here, you can quickly search for answers, raise questions, discuss and share your ideas
with other Trados Studio users.

7.12 Other enhancements
This topic lists the additional improvements introduced with Trados Studio 2021.

New filtering criteria for Studio projects and files
To make it easier to work with long lists of projects and project files, Trados Studio 2021
includes four additional search filters:


Project name, Customer name and Cloud projects filters in the Projects view



File name filter in the Files view

Better navigation and filtering for GroupShare projects
We improved the navigation in the Trados GroupShare Project Selection dialog box and
added new search filters to ensure faster access to Trados GroupShare projects from Trados
Studio.
Click File > Open Trados GroupShare Project and check out the new filters:


Project name



Due date



Status

Automated Translation paired with Machine Translation during pre-translation
The Apply Automated Translation option under Pre-translate Batch Task is now enabled by
default as soon as you add a Machine Translation provider. This helps you leverage more
content during pre-translation, but may affect your Machine Translation quotas. This change
does not apply if your active Machine Translation provider is a Language Cloud translation
engine. In this case, the default pre-translate setting is still Leave Target Segments Empty. If
you do want to apply automated translation from Language Cloud translation engines, enable
your engine during project creation instead.

More Automated Translation (AT) providers
Trados Studio can connect to Machine Translation via Language Cloud to generate automated
translations. You can access many other Automated Translation providers, including Google
Cloud Translation and DeepL, from the RWS AppStore.
To find and install third-party AT providers, go to the Add-ins tab > RWS AppStore and search
for apps in the Automated Translation category.
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GroupShare project files are updated in the background
You can now continue working on your GroupShare project while Studio is uploading your
saved changes back to the GroupShare server. The uploading progress is now shown in the
Trados Studio status bar so that you no longer have to wait for the upload to finish before you
can resume work.

Quick Add Term operation performed in the background
When using Quick Add Term in the Editor view to quickly add a new termbase entry, the
Termbase Viewer window no longer slides out to show the update. Instead, it adds the new
term completely silently in the background.
If you do need to check the new term in the Termbase Viewer window, right-click on selected
segment content and choose Add Term instead.

Faster Editor view
The Editor view includes significant performance improvements that translate into:


faster processing of long documents



faster selection of multiple segments



faster segment merging and splitting



faster document alignment

Faster QA checks
The performance of the QA Checker has been improved to enable Trados Studio to run QA
checks faster.

Faster processing of long lists of translation memories
Trados Studio can now instantly switch to Project Settings and to the Translation Memories
view, even when these views contain long lists of translation memories.

Faster processing of large packages
Trados Studio can now process better any project packages that contain over 1000 files. Such
packages are now opened approximately 20% faster.

Confirmation required before cancelling batch tasks in progress
Trados Studio now displays a warning message if you are trying to close Studio while batch
tasks are running. This ensure that you do not accidentally cancel background tasks.
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Added support for YAML and Email file types
With this release we are extending Trados Studio's wide-range of compatible file types. You can
now also translate YAML files and the following types of email files:


*.MSG



*.EML



*.EMLX



*.OFT

To change the default settings for extracting translatable content from these file types, go
to:


File > Options > File Types for global settings.



Home > Project Settings > Options > File Types for project settings.

Enhancements to existing file types


Subtitle file type replaces Subrip. Besides SubRip files (.SRT), the new Subtitle file type
also supports WebVTT (.vtt) and SubView (.sub, .sbv) subtitling formats.



Revamped Adobe FrameMaker file type. Trados Studio 2021 defaults to a new, better
and faster version of the Adobe FrameMaker 8-2020 file type.



The new XML file type is now listed above the legacy XML file type in the default order
of file types. This means that new XML projects are processed using version 2 of the
XML file type instead of the legacy one.

One central location for all Data files
All Trados Studio data files have been moved to one unified location in the user profile folder. If
you are an advanced user who needs to modify the Trados Studio settings manually, you can
now find all data files inside the Studio16 folder.
The Studio16 folder is available in the following local path C:\Users\\AppData\Roaming \SDL\SDL
Trados Studio\Studio16. Here you will find all Trados Studio data files, including Logs,
UserProfiles and UserSettings files.
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Issues resolved in Trados Studio 2021

This list details the issues that were resolved in Trados Studio 2021:


CRQ-16988: The upload progress for server-based projects is now displayed in the
status bar instead of prompting a dialog box. This enables you to continue working on
server projects while your changes are uploaded back to the Trados GroupShare
server.



CRQ-17192: Fixed access issue to WorldServer group TMs that restrict TM updates to a
specific user.



CRQ-12492: Fixed issue with opening alignment files that specify TMs located on
unavailable servers.
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Installing Trados Studio

This section contains general information on installing Trados Studio 2021 and the technical
requirements for the installation.
For step-by-step instructions on how to install and maintain Trados Studio, see the Trados
Studio 2021 Installation Guide.

9.1

Installation requirements

Hardware requirements


A Microsoft Windows-based PC or an Intel-based Apple Mac computer running
Windows as an operating system



Up to 2.5 GB of available disk space to run the Trados Studio 2021 installer



2 GB of available disk space to run Trados Studio



A 32-bit (x86) or 64-bit (x64) processor




32-bit (x86) OS


1 gigahertz (GHz) or faster processor



8 GB RAM



A screen resolution of 1280x1024 pixels and 256 colors or higher

64-bit (x64) OS


A recent processor with dual or multi-core technology



8 GB RAM



A screen resolution of 1280x1024 pixels and 256 colors or higher

Optimum performance
For optimum performance, RWS recommends using:


64-bit operating systems



a recent processor with dual or multi-core technology



16 GB of RAM and SSD storage



a recent Intel or compatible CPU

Operating Systems
Supported OS


Trados Studio 2021 SR2 runs on the latest version of Windows 11, Windows 10 and
Windows 8.1.
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Trados Studio also supports Windows Server 2016, Windows Server 2012 R2 and
Windows Server 2008 R2 to facilitate certain scenarios, for example, where Citrix or
Remote Desktop Services are used.

Limited Windows 7 support
Microsoft has recently stopped support for Windows 7. As a result, we are no longer testing or
supporting Trados Studio on Windows 7.
However, if you intend to remain on Windows 7, you may be able to do so successfully for the
time being by enabling TLS 1.2 as default secure protocol. Language Cloud (Trados Live) and
GroupShare 2017 SR2 and later only accept TLS 1.2 connections to ensure the highest data
security when sharing projects on our servers.
Unsupported OS
Trados Studio does not support earlier operating systems such as:


Windows 8



Windows 7



Windows Vista



Windows XP



Windows 2003 Server

Recommended OS
We recommend that you use Windows 10 because it is the current and best supported OS from
Microsoft. Windows 11 is also supported as the recent successor to Windows 10.

Microsoft Office
Trados Studio 2021 SR2 offers full, out-of-the-box support for all Microsoft Office 2021,
Microsoft Office 2007-2019 and 2000-2003 file formats.
Trados Studio can process these versions of Office files even if you do not have Office installed
on your computer. However, you may want to install Microsoft Word and PowerPoint to:


preview translated Word, Excel and PowerPoint documents in their native format,
outside Trados Studio.



use the Word spell-checker in the Editor instead of the default Hunspell that is installed
with Trados Studio.

For spell-checking, Trados Studio requires Microsoft Office 2021, 2019 or 2016. Older
versions might also work but are not tested. As a general rule, Trados Studio supports the
latest and previous generation of any third-party product.

Browsers


The Welcome tab with drag-and-drop capabilities is only available on PCs with
Microsoft Internet Explorer 10 or later.
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On PCs with Microsoft Internet Explorer 9 or earlier, the old Welcome tab content is
displayed.



The Language Cloud dashboard and Language Cloud Terminology require the latest
version of Microsoft Edge, Google Chrome and Mozilla Firefox to work.

Trados Studio Help
The Trados Studio Help buttons are context-sensitive and redirect to the online deliverable on
the Documentation Center. This means that to get access to the latest updated Help for Trados
Studio you need an Internet connection and one of the following Internet browsers installed:


Microsoft Edge



Google Chrome (latest version)



Mozilla Firefox (latest version)



Safari 7 and later



Microsoft Internet Explorer 10 and later

If you need to consult the full product documentation in a location with no Internet access, you
can download the WebHelp documentation deliverable, a ZIP file containing all the
documentation as static Web pages.
To download the ZIP file, access the following link Trados Studio 2021 SR2 full documentation as
WebHelp deliverable. Unpack this ZIP file in a location of your choosing and open index.html in
an Internet browser.
Please note that the documentation may be subject to change after the product has been
released. The live documentation resource in the Documentation Center is always the most upto-date resource.

9.2

Installing and upgrading

Trados Studio 2021 SR2 installation
You can download the Trados Studio 2021 SR2 installer from My account.
When installing Trados Studio 2021 SR2, make sure that you have administrator rights and that
no other software is running.
Trados Studio 2021 SR2 installs side-by-side with previous major versions of Trados Studio.
However, as a service release for Trados Studio 2021, Trados Studio 2021 SR2 installs on top of
previous Trados Studio versions and cannot run alongside them.
You can find a full list of the software, including third-party software installed with Trados
Studio in the Trados Studio Installation Guide
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Licensing Trados Studio

For detailed instructions on how to activate permanent and subscription Trados Studio licenses,
see the Licensing Help.
For any licensing or installation issues, contact support here:
https://gateway.sdl.com/liveagentlicensing

10.1 Upgrading from Trados Studio 2019
After upgrading from Trados Studio 2019 to Trados Studio 2021, your original license will be
automatically removed from your account.
If you want to use Trados Studio 2021 side-by-side with Trados Studio 2019, you can use both on
the same machine using the Trados Studio 2021 license. This is only possible for single-user
licenses.

10.2 Upgrading from Trados Studio 2017 or 2015
After upgrading from Trados Studio 2017 or 2015 to Trados Studio 2021 SR2, your original
license will be automatically removed from your account. To continue using an older version,
you should consider purchasing a full license instead of an upgrade.
If you want to try Trados Studio 2021 SR2 side-by-side with Trados Studio 2017 or 2015, you can
use the 30-day trial that is available in Trados Studio 2021 SR2.

10.3 Licensing Trados Studio 2021 SR2 from Trados Studio 2021
If you have a Trados Studio 2021 perpetual or subscription license, you can upgrade to Trados
Studio 2021 SR2 for free.
As a service release for Trados Studio 2021, Trados Studio 2021 SR2 shares the same activation
codes and cloud credentials.

10.4 Using Trados Studio 2021 SR2 with a network license
Trados Studio 2021 SR2 uses licensing technology based on SafeNet network licensing. To
activate Trados Studio 2021 SR2 network licenses you need the latest version of Trados License
Manager.

Multiple product editions on a license server
In Trados Studio 2021 SR2, you can connect to a network license server that has multiple
product licenses active and choose what Trados Studio edition to use. For more information on
how to connect to a license server, see the Licensing Help.
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Remote Desktop connections
When using a Remote Desktop Connection, you can run more than one instance of Trados
Studio on the remote workstation; however, each instance will consume a network seat.
When using Remote Desktop Services or Citrix XenDesktop, you can only activate Trados Studio
with a network license. Each user session consumes one network seat until all available seats
are exhausted.

10.5 Network licensing when upgrading from a previous version
Upgrading from Trados Studio 2011 and 2014 pre-SP2
If you are a Trados Studio 2011 or 2014 pre-SP2 user upgrading to Trados Studio 2021 SR2 in a
network-licensing scenario, install the new Trados License Manager to activate the Trados
Studio license. You can continue to use Trados Studio 2011 or 2014 pre-SP2 with network
licensing using the legacy License Server Toolkit.

Upgrading from Trados Studio 2014 SP2, 2015, 2017 or 2019
If you are a Trados Studio 2014 SP2, 2015, 2017 or 2019 user upgrading to Trados Studio 2021
SR2 in a network-licensing scenario, upgrade to the latest version of Trados License Manager to
activate the Trados Studio license.
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Compatibility

This section lists the previous Trados Studio versions that Trados Studio 2021 SR2 is compatible
with. It also offers information on special compatibility with other important software.

11.1 Compatibility with previous Trados Studio versions
Trados Studio 2021 SR2 can run alongside previous versions of Trados Studio.
However, as a service release for Trados Studio 2021, Trados Studio 2021 SR2 installs on top of
previous Trados Studio 2021 versions and cannot run alongside it.

Compatibility with Trados Studio 2015, Trados Studio 2017 or 2019
Trados Studio 2021 and Trados Studio 2015, Trados Studio 2017 or 2019 have the same project
and package format.
Plug-in for Trados Studio 2015
Trados Studio 2015 users can use TMs generated in Trados Studio 2017 SR1 CU15 and later, if
they first convert these TMs using the TM Compatibility Plug In.
1. Go to RWS AppStore and download the TM Compatibility Plug In for free.
2. Run the Plugin installer.
3. Open Trados Studio 2015.
4. Go to the Home tab, select Back Convert TM, browse for the TM and select Yes.
Trados Studio 2015 users can also be prompted to back convert their TM at the end of the
Project Creation wizard or when they add the TM as a new resource to an existing project.
Plug-in for Trados Studio 2021 SR2
You can also install Trados Studio 2021 SR2 alongside Trados 2007, Trados Workbench and
SDLX.
To open and work with files created in these legacy versions, first install the Trados
Compatibility and Migration Power Pack app from the RWS AppStore. This free app adds the
infrastructure required to work with the following legacy files in Trados Studio 2021 and later:


S-tagger



Bilingual Workbench



*.TMW



*.MDB



*.ITD



*.TTX

To install the app, go to the Add-Ins tab > RWS AppStore.
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Compatibility of older TMs with Trados Studio 2021 SR2
When using a TM from an earlier Trados Studio release with the latest Trados Studio release,
you will have no problem accessing its resources during translation. However, you will not be
able to benefit from the latest TM performance enhancements related to upLIFT fragment
matches, upLIFT MatchRepair, fuzzy matches and context matches.

Tip: We recommend that you upgrade all your older or earlier TMs to the latest Trados Studio
release version by using one of the available Translation Memory Upgrade mechanisms. All TMs
which require an upgrade (either because they are older or they require reindexing because
their settings have changed) are flagged with an exclamation mark.

Compatibility of cloud projects opened in Trados Studio 2021 with older Studio versions
Starting with the Trados Studio 2021 release, you can create, download, and work with cloud
projects directly from Trados Studio. Cloud projects that you download locally in Trados Studio
2021 cannot be opened in previous versions of Trados Studio that might be installed side-byside with Trados Studio 2021 on your machine. This is because previous versions of Trados
Studio use different mechanisms to open cloud projects and do not support the latest
refinements.
However, cloud projects are also compatible with Trados Studio 2019 and 2017. If you work with
Trados Studio 2019, you can download them using the Open in Studio button in the browser
user interface. It is also possible to download project packages from the browser. These are
compatible with Trados Studio 2021, 2019 and 2017.

11.2 Compatibility with other software


Passolo - Trados Studio 2021 SR2 is compatible with the latest CUs available for Passolo
2018 and Passolo 2022.



MultiTerm Desktop - You can use MultiTerm 2021 and MultiTerm 2019 on the same
computer as Trados Studio 2021 SR2.



Trados GroupShare - Trados Studio 2021 SR2 is compatible with Trados GroupShare
2020 and 2017.
Trados Studio 2021 SR2 does not work with Trados GroupShare 2015 and below.



Language Cloud (Trados Live) - Cloud projects are compatible with Trados Studio
2021, 2019 and 2017. In Trados Studio 2021, you can create and work with cloud
projects both from Trados Studio and your cloud account. If you work with Trados
Studio 2019, you can download cloud project packages from the browser and open
them from Trados Studio using the Open in Studio button in the browser user
interface.



SDL TMS - Trados Studio 2021 SR2 is compatible with all bilingual files and packages
created in SDL TMS 12.x.
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SDL TMS and Trados Studio extraction settings
Currently, SDL TMS does not include an auto-update feature to immediately match the changes
that Trados Studio makes to its File Types via Cumulative Updates. This means that sometimes
you may find differences between file content extracted as translatable text in Trados Studio
and in SDL TMS. To ensure full compatibility between Trados Studio and SDL TMS, we
recommend that you use the version of Trados Studio that contains the same set of File Types
as your SDL TMS. You can also manually configure the SDL TMS Content Types settings to
synchronize the content extraction logic.
For more information on which version of Trados Studio is in line with SDL TMS, contact Support
or check the SDL TMS release notes.
WorldServer
Starting with the 2021 release, Trados Studio has migrated support for WorldServer projects to
a dedicated app available in the RWS AppStore. To work with bilingual files and packages,
including Live TM connections, created in WorldServer 11.x and 10.4.5, go to the Add-ins tab >
RWS AppStore and install the free WorldServer Compatibility Pack for Studio.

11.3 Upgrading to Trados Studio 2021 and MultiTerm 2021
To avoid any usage incompatibility between Trados Studio and MultiTerm, you must upgrade
both these products to their latest version.
1. Exit Trados Studio 2019 and MultiTerm 2019, and close any Microsoft Office applications.
2. Log in to your My Account.
3. Go to the Downloads section.
Your Trados Studio 2021 SR2 and Trados Studio download is clearly marked.
4. Expand the new Trados Studio 2021/MultiTerm 2021 product name and you will find the
required downloads.
5. Select Download for each application and save the executable files to your local hard
disk.
6. Run both .exe files one at a time and follow the wizard-driven process.
Results
The Trados Studio 2021 installer will detect the currently installed Trados Studio 2019 software
and uninstall it in the background before installing Trados Studio 2021. If you have any
problems with the installation or licensing of Trados Studio 2021 please submit a request in the
Solution Finder. The same applies for any issues you may encounter with MultiTerm 2021.
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Supported releases

Trados Studio 2021 SR2 is the most recent fully supported release of Trados Studio.
RWS continues to support Trados Studio 2019 until the next version of Trados Studio will be
released.

Retired releases
On the 31st of January 2021, Trados Studio 2017 has been moved to an End-of-Life state, along
the following already retired versions: Trados Studio 2015, 2014, 2011 and 2009.
RWS does not provide technical assistance, issue service packs or hotfixes for retired releases.
For Trados Studio 2021 and Trados Studio 2019, RWS will issue service releases and cumulative
updates as and when required.
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Further information

This section lists the resources available for getting more help and information on Trados
Studio 2021 SR2.

13.1 Help
Trados Studio Help
The Help for Trados Studio 2021 SR2 is available by selecting Help tab > Help Topics in Trados
Studio. You can also go to the RWS Documentation Center to access the Trados Studio Help.
Here you can find links to:


Information on installing and upgrading to Trados Studio 2021 SR2



Videos and information on how to get started with Trados Studio



Help topics about working with Trados Studio and Trados GroupShare projects

Trados GroupShare Help
If you are working with Trados GroupShare projects, you may also find the Trados GroupShare
Help useful. Here you can find links to:


Information on installing and upgrading Trados GroupShare



Help topics describing how to work with Trados GroupShare

MultiTerm Help
For information on working with termbases, see the MultiTerm Help.

13.2 Customer support
To contact Technical Support, connect to the Customer Support Web Portal at
https://gateway.sdl.com and log a case for your RWS product. You need an account to log a
case. If you do not have an account, contact your company's RWS Support Account
Administrator.

13.3 Creating a Support and Maintenance contract
You need valid Support and Maintenance contract to log a support case. If you do not have a
valid Support and Maintenance contract to see your Support options go to your RWS Account:


Go to https://www.rws.com



Select Account login and log in with your email and password.



Select your profile name and then Support.



Complete registration by filling in your details.

If you have any other issues regarding Trados Studio, go to Trados Translation Productivity
Community.
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Acknowledgements

Trados Studio includes open source or similar third-party software.
#ziplib
#ziplib (SharpZipLib, formerly NZipLib) is a Zip, GZip, Tar and BZip2 library written entirely in C#
for the .NET platform. It is implemented as an assembly (installable in the GAC), and thus can
easily be incorporated into other projects (in any .NET language).

Apache log4net
The Apache log4net library is a tool to help the programmer output log statements to a variety of
output targets. log4net is a port of the Apache log4j™ framework to the Microsoft® .NET runtime.

Hunspell
Hunspell is the spell checker of LibreOffice, OpenOffice.org, Mozilla Firefox 3 & Thunderbird,
Google Chrome, and it is also used by proprietary software packages, like Mac OS X, InDesign,
MemoQ, Opera and Trados Studio.

ICU (International Components for Unicode)
ICU is a mature, widely used set of C/C++ and Java libraries providing Unicode and Globalization
support for software applications. ICU is widely portable and gives applications the same results
on all platforms and between C/C++ and Java software.

SafeNet Sentinel
SafeNet's Sentinel software licensing products and software protection solutions provides
software publishers control and visibility into how their applications are deployed and used.

Spring.NET
Spring.NET is an application framework that provides comprehensive infrastructural support for
developing enterprise .NET applications. It allows you to remove incidental complexity when using
the base class libraries makes best practices, such as test driven development, easy practices.

WiX
The WiX toolset builds Windows installation packages from XML source code. The tool-set
integrates seamlessly into build processes.

Xerces-C++
Xerces-C++ is a validating XML parser written in a portable subset of C++.
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RWS Holdings plc is the world’s leading provider of technology-enabled language, content management and intellectual property services.
We help our clients to connect with and bring new ideas to people globally by communicating business critical content at scale and
enabling the protection and realization of their innovations.
Our vision is to help organizations interact effectively with people anywhere in the world by solving their language, content and market
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