Every time you click on a ttx file, a new TagEditor window opens

spiros · 1 · 1424

spiros

  • Administrator
  • Hero Member
  • *****
    • Posts: 823027
    • Gender:Male
  • point d’amour
Isn't that a bit unnerving? I mean it is basic behaviour of most software packages to open files in an already running instance of the program.

Be patient. The next major version might change this.


If you open a ttx file by double click the TagEditor will always new started. Maybe it is easier to open the file into a running Tageditor. And please add an option to open the ttx file without telling mi, that the languages of the Trados workbench are wrong because this dialog does not appear in the task bar and often it is hidden after other applications.

Until then, here is a fix for this behaviour (thanks to Heidi Van Hiel). Save the following text as a reg file and double click it. (Save it first as .txt and then change the extension to .reg)

Note: just tested the code and it does not work for Trados 8

Code: [Select]
[HKEY_CLASSES_ROOT\TagEditor.TRADOStagDocument\shell\open\ddeexec] @="[open(\"%1\")]"
[HKEY_CLASSES_ROOT\TagEditor.TRADOStagDocument\shell\open\ddeexec\Application] @="TAGEDI~1"
[HKEY_CLASSES_ROOT\TagEditor.TRADOStagDocument\shell\open\ddeexec\Topic] @="System"

http://ideas.sdltrados.com/ideas/detail.asp?i=657

How to Import Windows Registry Files

Sometimes just clicking on a .reg file is enough

Click the Start menu and click Run.
Type "regedit" and click OK.
Click Registry in the Registry Editor toolbar.
Click Import Registry File.
Browse to the directory containing the file (with .reg extension) and select the file.
Click OK to import the registry file
« Last Edit: 27 Jul, 2008, 21:19:51 by spiros »


 

Search Tools